Introduction

Using the GDA Software Interface

GDA Software Interface Menu Bar

GDA Software Interface Toolbar

Red text in this document indicates active internal hot links.

Blue text indicates active web links.

Bold text indicates words or phrases that may be used as cross-references between this document and labels, objects or hints in the software user interface.
1. Introduction

General Overview

Contents of the GDA

GDA Software Interface Main Features
1.1. General Overview

The GDA Software Interface provides the user with facilities for displaying, querying and exporting data from the GEBCO Digital Atlas. It has been developed to run under Microsoft® Windows® and is controlled by a system of drop down menus available from the **Main Menu Bar** and also buttons available from the **Toolbar**.
1.2. Contents of the GDA

The following data sets are available for display and export through the GDA Software Interface:

- The GEBCO one minute gridded data set

- A set of digital bathymetric contour, trackline control and coastline data sets for the world’s oceans (basic scale 1:10 million, but with updates at scales from 1:1 million to 1:250,000)

- A set of digital global coastlines from the US National Imaging and Mapping Agency’s World Vector Shoreline at a range of scales from 1:43 million to 1:250,000

- A set of coastlines for Antarctica supplied by the Scientific Committee on Antarctic Research at a range of scales from 1:10 million to 1:250,000

- A trackline inventory of the echo-sounding data held at the IHO Data Center for Digital Bathymetry, as of June 2002.

The GDA contains a digital set of geographically referenced feature names, including a digital copy of IOC/IHO Gazetteer of Geographical Names of Undersea Features for display purposes.

A digital version of the Third Edition of Echo-Sounding Correction Tables can be accessed through the software interface.
1.3. GDA Software Interface Main Features

The following features are available through the GDA software interface:

- GEBCO one minute grid display can be toggled on/off.
- Bathymetric contour data sets may be displayed from either the GEBCO Chart Series or, for the Mediterranean, the IBCM First Edition.
- Vector and gridded data from the GDA may be exported in a number of formats.
- A choice from the following coastlines may be displayed and exported with the data sets:
  - The coastline used in the chart series
  - The World Vector Shoreline (south of 60°S SCAR Antarctic Coastline)
- A choice of map projections is available to display the data:
  - Equidistant Cylindrical
  - Mercator
  - Lambert Cylindrical Equal Area
  - Miller Cylindrical
  - Polar Stereographic
- A choice of colour, line and symbol styles can be used to display the data.
- Initial geographic area selection can be made by chart number, by chart area, by geographic latitude and longitude limits or by a user controlled zoom box. This initially selected area becomes the ‘basemap’.
- Within the initially selected basemap area the user can zoom in and out of their particular area of interest and pan across to an adjacent area if required. Any export of data from the GDA will be based on the data in the area of the displayed map.
- A graticule can be overlaid on the plot for reference. The format of the graticule is controlled by menu options.
- The current cursor position and elevation value may be displayed.
• The echo-sounding correction value for a specified position can be displayed.

• A multi-point distance measuring facility is available with distance displayed in nautical miles, statute miles and kilometres.

• The bathymetric data may be overlaid with trackline control information. The information source is selected from either the GEBCO Chart Series or the data set available from the IHO Data Center for Digital Bathymetry. Please note that no trackline information is available for the IBCM data set. The GEBCO data set contains trackline control in the form of tracklines, isolated sounding points and survey boxes or a combination of these data types. The user may select these trackline control data types separately, but should be aware that they may all be valid in a particular area.

• The display can be overlaid with symbols showing the locations of undersea features, oceanic islands, ports/cities and Antarctic islands and stations. A cursor controlled querying facility is available for displaying the names of these features on the screen.

• A map key can be produced and toggled on/off.

• Vertical profile sections may be produced through the data displayed.

• The image displayed on screen can be printed or saved as a bitmap file.

• Plain language documentation covering the data sets contained with the GDA may be listed and/or printed.

• For the purposes of display within the GDA Software Interface the trackline control, undersea feature names, place names and island names are classed as Supplementary Data sets.
2. Using the GDA Software Interface

Getting Started
Quick Start Instructions
Export Formats
Chart Definition Dialog Box
Export Data Dialog Box
2.1. Getting Started

Following the splash screen, the **Chart Definition Dialog Box** is displayed. From here the user can select:

- The geographic area required.
- The required data sets.
- The required map projection.
- The colours and line styles to be used with the data.

As discussed in the **Quick Start Instructions** this is a good method of setting up the required data sets and plot parameters in one go without going through the individual menu options.

The user can select to close the **Chart Definition Dialog Box** and make their selections from the options from the Main menu.
2.2. Quick Start Instructions

The **Select** menu facilitates selection of the data sets that the user wants to display on screen or export, the colours and line styles to be used with the data sets and the map projection to be used to display the data. Items chosen from the **Select** menu will not be displayed on screen unless it has been toggled for display from either the **Display** menu or through the options from the **Chart Definition Dialog Box**.

A useful short cut is to launch the **Chart Definition Dialog Box** from the **Select** menu to set up a number of these options in a single operation.

The **Display** menu allows the user to choose which of the selected data sets are to be displayed. This can also be done through the **Chart Definition Dialog Box**.

The **Auto Redraw** facility on the **Display** menu is used to prevent the screen being redrawn each time a new dataset is selected or made available for display. This eliminates unnecessary delays.

The colours and line styles used for displaying the available data sets can be changed from the menu options available from the **Select** menu from the **Chart Definition Dialog Box**.

Any of the five available map projections used to display the data may be selected from the **Select** menu or from the **Chart Definition Dialog Box** available from the **Select** menu.
2.3. Export Formats

It is possible to export both the vector and gridded data sets through the GDA Software Interface. This is achieved through the Export Data option under the File menu. Formats are included that are compatible with the GMT (Generic Mapping Tools) system (http://gmt.soest.hawaii.edu/), ESRI and AUTOCAD software packages.

Export of the Gridded Data Set

The GEBCO grid is one minute of latitude by one minute of longitude, stored in grid line registration format. The entire grid or any subset may be exported in a simple ASCII format or as a NetCDF file (http://www.unidata.ucar.edu/packages/netcdf/).

The elevation values are stored as signed 2-byte integers with the convention that bathymetric depths have negative values and topographic heights have positive values.

ASCII Format

The following options are available through the Export Data Dialog Box:

- Export the data in the format: longitude latitude elevation. Longitude and latitude formats may be selected from the following options:
  - decimal degrees
  - degrees and decimal minutes
  - degrees, minutes and decimal seconds

- Export the elevation data only, as either one data point per line or one row of data per line. In the latter case, the data values may be separated by commas, spaces or output in a fixed-width format.

For all ASCII grid export formats:

- The export file has 11 header records.
- The grid points are read eastwards from the Northwest corner of the selected data area.

NetCDF Format

The GEBCO gridded data set is stored in NetCDF as a one dimensional array of 2-byte signed integers that represent integer elevations in metres. The data start at position 90°N, 180°W and increase eastward from there.
Export of the Vector Data Sets

This includes the bathymetric contour, coastline and trackline control data sets. The vectors may be exported in a simple ASCII format, DXF format or ESRI Shapefile format.

In the data files, latitude is stored in the range -90° to +90° with north positive and south negative; and longitude is stored in the range -180° to +180° with east positive and west negative. However, the user can select that the longitude data are stored in the range 0° to 360°. This can be set through the Select – Graticule menu or the Chart Definition Dialog Box.

ASCII Format

ASCII files are built up as a series of labelled vector streams relating to bathymetric contours, coastlines, tracklines, survey box outlines or sounding points.

A new vector stream is started for each contour segment, coastline segment, trackline, survey box outline or isolated sounding point.

Each vector stream consists of co-ordinate pair records preceded by a header record containing a flag character, set to ‘>’, feature code 'ICODE' for the vector and a count 'ICOUNT' of the number of succeeding co-ordinate pairs making up the vector. Note that the ‘>’ character was not included in previous versions of the GDA ASCII export format.

Each co-ordinate pair is stored in a record with a geographic latitude 'ALAT' and longitude 'ALONG', expressed in decimal degrees.

Each 20-byte record is made up as follows:

- Header record: IFLAG, ICODE, ICOUNT in format (A1,2I6,5X),CR,LF
- Coordinate pair record: ALAT, ALONG in format (F8.4,F10.4),CR,LF

The feature code definitions are:

- '0' for coastlines
- '1' for landward limit of seawater (Antarctic coastline)
- '2' for seaward limit of floating permanent ice (Antarctic coastline)
- 'depth in corrected metres' for bathymetric contours
- '22010' for ice coastline (definite)
- '22011' for rock coastline (definite)
- '22012' for grounding line (definite)
- '22013' for rock against ice shelf (definite)
- '22020' for ice coastline (approximate)
- '22021' for rock coastline (approximate)
- '22022' for grounding line (approximate)
• '22023' for rock against ice shelf (approximate)
• '22030' for iceberg tongue
• '22040' for floating glacier tongue
• '22050' for ice shelf front
• '22090' for ice rumples (distinct)
• '22100' for ice rumples (indistinct)
• '22222' for tracklines
• '22223' for outlines of survey boxes, special compilations or areas of dense sounding coverage
• '22224' for isolated sounding point positions

**Note:** Codes '1', '2', and '22010' to '22100' correspond to Antarctic related coastlines. Codes '1' and '2' are only present when the user has requested that feature codes '22010' to '22023' and '22090' and '22100' should be combined into code '1' and feature codes '22030' to '22050' into code '2'.

**DXF**

DXF originated as a proprietary format in the commercially available 'AUTOCAD' package, but is now a standard input format for many other commercially available software packages.

In DXF, the vector streams are expressed as polylines in geographic co-ordinates with each contour depth and coastline feature type assigned to a separate layer and a separate logical colour. Likewise, separate layers and logical colours are also assigned for tracklines, survey boxes and isolated sounding points. The latter are expressed as type POINT rather than polylines. Each of the layers is labelled using the feature code definitions listed in the ASCII format definition above.

**Shapefile**

This format is used by ESRI products such as ARCINFO. Further information about the Shapefile format may be found in [http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf](http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf).

Line and point feature types may be exported in ESRI Shapefile format. Bathymetric contour, coastline and trackline data are exported as line feature types and isolated soundings as point feature types. Line and point feature types are exported to separate files.

The Shapefile consists of a main file, an index file and a dBASE table. When the user enters a file name from the **Export Data Dialog Box** three files will be created. For example, if the data are saved with the name area1.shp, files 'area1.shx' (index file) and 'area1.dbf' (dBASE file) will also be created. A further set of three files ('area1Soundings.dbf', 'area1Soundings.shp' and 'area1Soundings.shx') will be created should the exported data include point features. If the exported data consists of only point features then the chosen name is used.
Ordering of Vectors

Vector data may be exported in ordered format (check the **Ordered** button in the **Structure** section of the **Export Data Dialog Box**). Ordering is by feature code and then by depth. Thus any ‘0’, ‘1’ or ‘2’ coastline vectors will appear before the bathymetric contour vectors which, in turn, will be arranged in ascending order of their depths. If present, the detailed Antarctic coastlines will follow the bathymetric contours and then be followed by tracklines, survey box outlines and isolated sounding points.

Ordering the data creates temporary disk files on the users PC. Exporting data for a large area may require a large amount of free disc space.

Contiguity of Vectors

Within the GDA system the vector data sets are split into ten degree squares. The user can select to join up the vector segments on export by checking the **Contiguous** button from the **Structure** section of the **Export Data Dialog Box**. This option is only available if the user has selected to save the data in ordered format as described above.
2.4. Chart Definition Dialog Box

The **Chart Definition** option from the **Select** menu opens up the dialog box shown above. It is also opened when the user starts a new GDA session.

It allows the user to setup the map parameters and data sets required for display and export. All options available are also available from the **Select** and **Display** menus.

The dialog box includes the following tabbed sections:

**Data Source**

This section offers the following options for sourcing the bathymetric contours, coastlines and the trackline control.

- **Chart Series** – specify bathymetric contour data from either the GEBCO or IBCM chart series.
• **Trackline Source** – specify data from either GEBCO or IHO DCDB data sets. The selected data will be used for any subsequent trackline control displays or data exports.
  
  o **GEBCO** – trackline control information is taken from the GEBCO data set. The GEBCO trackline control represents the data coverage available for the compilation of the bathymetric contours for the GEBCO chart series. No digital trackline control is available for the IBCM dataset.
  
  o **IHO DCDB** – trackline information is taken from the International Hydrographic Organization Data Centre for Digital Bathymetry (IHO DCDB). This trackline information is supplied solely for the purpose of indicating the coverage of digital bathymetric data available from that source. The IHO DCDB data were not used in the compilation of either of the bathymetric contour datasets supplied (GEBCO or IBCM), and should not, therefore, be used as any indication of the confidence that may be placed in contours for a given area.

If the user selects ‘GEBCO’ for the Chart Series then the following options area available for the coastline data sets:

• **GEBCO Coastline Resolution** – specify the coastline data set to be used for all subsequent display and/or export. The options available are:
  
  o **GEBCO Coastline Resolution** – causes subsequent contour plots or data exports to include the coastline included in the GEBCO digital bathymetric contour data sets. Refer to the documentation (Info menu) which accompanies the digital bathymetric contour data sets for further information.
  
  o **WVS Auto Resolution & SCAR Auto Resolution** – selects an appropriate scale of coastline from the World Vector Shoreline (WVS) dataset. South of 60°S the Scientific Committee on Antarctic Research (SCAR) coastline is used rather than WVS. Refer to the documentation (Info menu) for further details on these coastline data sets. The display system automatically selects the source scale most appropriate to the current screen display scale or the source may be specified manually using the options that follow.
  
    o **WVS Full Resolution & SCAR Full Resolution**
    o **WVS 1:250000 & SCAR Full Resolution**
    o **WVS 1:1000000 & SCAR 1:1000000**
    o **WVS 1:300000 & SCAR 1:5000000**
    o **WVS 1:1200000 & SCAR 1:10000000**
    o **WVS 1:4300000 & SCAR 1:10000000**

When Auto Resolution has been selected for display of the coastline data sets, then on export and display the following will be used:
o Latitude and longitude range of less than 5 degrees – Full Resolution WVS and SCAR

o Latitude and longitude range greater than 5 degrees but less than 15 degrees – WVS 1:250000 & SCAR Full Resolution

o Latitude and longitude range greater than 15 degrees but less than 60 degrees – WVS 1:1000000 & SCAR 1:1000000

o Latitude and longitude range greater than 60 degrees but less than 150 degrees – WVS 1:12000000 & SCAR 1:1000000

If the user selects 'ICBM' as the Chart Series then the following coastline data sets are available.

o **ICBM 1: 1 000 000** – causes subsequent contour plots or data exports to include the coastline included in the IBCM digital bathymetric contour data sets. Refer to the documentation (Info menu) which accompanies the digital bathymetric contour data sets for further information.

o **WVS Auto Resolution** – selects an appropriate scale of coastline from the World Vector Shoreline (WVS) dataset. Refer to the documentation (Info menu) for further details. The display system automatically selects the source scale most appropriate to the current screen display scale or the source may be specified manually using the options that follow.

o **WVS Full Resolution**

o **WVS 1:250000**

o **WVS 1:1000000**

o **WVS 1:3000000**

o **WVS 1:12000000**

o **WVS 1:43000000**

When **Auto Resolution** has been selected for display of the coastline data sets, then on export and display the following will be used:

o Latitude and longitude range of less than 5 degrees – Full Resolution WVS.

o Latitude and longitude range greater than 5 degrees but less than 15 degrees – WVS 1:250000.

o Latitude and longitude range greater than 15 degrees but less than 60 degrees – WVS 1:1000000.

o Latitude and longitude range greater than 60 degrees but less than 150 degrees – WVS 1:12000000.
Area

This section allows the selection of the required geographic area and map projection details. The chart series selection made from Data Source will affect the options presented.

The options available are:

- **Chart Name** – specify the area for which data are to be selected for display and/or export by the chart data set name. The required chart data set can be selected from the drop down menu. Refer to the documentation (Info menu) for further details on the available data sets. Please note that the area selected will contain all data originating from the designated data set, but may also include data from adjacent data sets where the area is irregular in outline.

- **Select from the Map** – select data sets from a displayed world map. This can be done either by selecting the Use Chart Outlines or Use Zoom button and clicking Select Area.
  
  - **Use Chart Outlines** – displays a world map with the chart data set limits superimposed. A chart may be selected by double-clicking in the area. Please note that the area selected will contain all data originating from the designated data set, but may also include data from adjacent data sets where the area is irregular in outline. Additionally, note that the limits of the selected chart are now displayed in the Exact Area panel. It is possible to refine the selection at this stage by altering the values shown in this panel.
  
  - **Use Zoom** – displays a world map on which an area of interest may be specified by selecting (left mouse click) diagonally opposite corner points. Note that the limits of selected window are now displayed in the Exact Area panel. It is possible to refine the selection at this stage by altering the values shown in this panel.

- **Exact Area** – specify precise geographic limits of the area of interest by entering the co-ordinates in decimal degrees, degrees and decimal minutes or degrees minutes and seconds. The format is chosen by the toggle buttons (press Degrees or Minutes) located in the bottom right-hand corner of the Exact Area panel. The hemispheric indicators are changed using the buttons to their right.

- **Projection** – specifies which of five available map projections is used when the selected data are plotted. Data exported from the system are independent of any cartographic projection. The projections available are:
  
  - Equidistant Cylindrical
  - Mercator
  - Lambert Cylindrical Equal-Area
- Miller Cylindrical
- Polar Stereographic – Please note that this option is only available for polar region data sets. From the initial area selection the region includes either 90°N or 90°S and the longitude range is 0°-360°E. If this option is selected the Central Meridian value to be used for producing the plot may be chosen.

**Palette**

This section allows the colour scheme used to display the currently selected elevation data to be specified from six basic colour palettes, including black and white. The sense of these palettes can be reversed by clicking the Reverse button.

- **Colour Schemes** – select from: **Red, Green, Blue, Rainbow, Light Rainbow and Black & White**.

- **Depth Range** – select one of two methods to determine the depth range from which the colour palette will be generated.
  
  - **Use Global Range** – calculate the colour palette using the full range of depths from the GEBCO one minute grid.
  
  - **Use Basemap Range** – calculate the colour palette using the range of depths from the GEBCO one minute grid included in the currently selected basemap area.

- **Palette Gradation Style** – select a palette with either **Discrete** or **Continuous** colour levels. When the **Discrete** option is selected the user can select the step size in metres.

**Contours**

This section allows selection of contours that are to be displayed. Individual contours may be selected, or various combinations, by using the left mouse button combined with the **Control** and **Shift** keys in the usual Windows manner. Three buttons offer the following options:

- **Select All** – selects all the available contours from the GEBCO and IBCM chart series.

- **Invert** – inverts the previous selection of bathymetric contour depths. For example, if **Select All** has previously been used, **Invert** will deselect all bathymetric contours.

- **500s** – selects only the contours at 500 metre intervals.

**Chart View**

This section allows selection of the colour and, in the case of the contours, the line style used to display some of the data sets. The user can also decide to select the data set for display.
The following features are included:

- Bathymetric Contours
- Unselected Contours
- Overlay Contours
- Coastline
- Background
- Gridded Data
- Single Colour Land

The colour selection for the Bathymetric Contours and the Gridded Data are determined using the Palette section above.

- **Display** – this option allows the user to decide to display the available data sets. This is done by checking the **Display** button.

- **Contour Line Styles** – this option allows the user to select the line style to be used for plotting the bathymetric contour data. The options available are: cyclic, solid, dash, dot.

**Supplementary Data**

This section allows the selection of data sets other than contours and gridded data and, the setting of their colours and styles.

The features that can be selected are:

- Tracklines
- Survey Boxes
- Isolated Soundings
- Undersea Features
- Islands
- Place Names

The colours used for display are changed by clicking the button in the **Colour** column and then making a selection from the displayed colour palette.

The styles are changed by clicking the button in the **Style** column and selecting one of the line styles or point styles displayed.
Graticule

This section allows the user to select the degree format and the spacing, colour and style of the chart graticule, and whether it is displayed or not.

- **Format** – sets the format of the graticule label as:
  - Degrees Minutes Seconds
  - Decimal Degrees.

- **Display** – sets the format of the longitude values displayed on the graticule and in any export of the vector data sets. The options available are:
  - 0...360 – the longitude values will be stored in the range 0° - 360°.
  - 180..0..180 – the longitude values will be stored in the range 180°W to 180°E with east positive and west negative.

- **Spacing** – sets the graticule spacing. It may be set to:
  - Auto Spacing – the software decides the appropriate graticule and changes it when zoom operations take place.
  - Fractional – a graticule is drawn with fractional grid spacing
  - 1 deg, 2 deg, 5 deg, 10 deg and 20 deg – sets the graticule spacing to the value selected.

The graticule colour is changed by clicking the Colour button and selecting a colour from the displayed colour palette. Care should be taken not to select a colour for the graticule that is the same as the gridded data when displayed.

SCAR Ice Codes

This section allows control of how the SCAR coastline data set is displayed.

- **Display Ice As** – display the SCAR coastline as Separate Ice Features or Grouped Ice Features.
  - Separate Ice Features – the full range of ice feature codes will be used.
  - Grouped Ice Features – the ice feature codes will be grouped into ‘Landward limit of seawater’ and ‘Seaward limit of floating permanent ice’.

- **Colour** – select the colour to be used for the individual SCAR coastline feature type by clicking the coloured button.

- **Line Styles** – select the line style to be used to plot the SCAR coastline feature type by clicking the coloured button.

- **Display** – toggles the display of the SCAR coastline feature type.
2.5. Export Data Dialog Box

This allows the export **Gridded Data** or **Vector Data** from the GDA.

**Vector Data**

Vector data may be exported in ASCII, DXF or Shapefile formats (see **Export Formats**), providing a vector data set has been selected, using this instance of the dialog box.

![GEBCO Centenary Edition: Export Data Dialog](image)

In the data files, latitude is stored in the range \(-90^\circ\) to \(+90^\circ\) with north positive and south negative; and longitude is stored in the range \(-180^\circ\) to \(+180^\circ\) with east positive and west negative. However, the user may choose longitude data stored in the range \(0^\circ\) to \(360^\circ\) through the **Select – Graticule** menu or the **Chart Definition Dialog Box**.
Gridded Data

GEBCO one minute gridded data may be exported in NetCDF or ASCII formats (see Export Formats) if the gridded data set has been selected using this instance of the dialog box.

The primary selection option is **Format** which allows:

- ASCII with a latitude and longitude for each depth value.
- ASCII depth values only.
- GMT- compatible NetCDF (2-byte signed integer).

If the first option is selected then the following control is given on how latitude and longitude are presented:

- **Format** – chosen from:
  - decimal degrees
  - degrees and decimal minutes
  - degrees, minutes and decimal seconds

  The number of decimal places used for each field in all of these options is controlled using the text boxes in the top right of the box.

- **Longitude convention** – chosen from:
  - **0..360 degrees** – longitude values in the range 0° - 360°
  - **-180..0..180 degrees** – longitude in the range 180°W to 180°E with east positive and west negative
  - **180..0..180 degrees (W,E)** – longitude values in the range 180°W to 180°E with west and east labelled as 'W' and 'E' respectively
• Latitude convention – chosen from:
  o 90°..0°..-90 – latitude in the range 90°N to 90°S with north positive and south negative
  o 90°..0°..90 (N,S) – latitude in the range 90°N to 90°S with north and south labelled ‘N’ and ‘S’ respectively.

For detailed information on how the exported data are presented see Export Formats.
3. GDA Software Interface Menu Bar

The Main Menu Bar contains the following drop-down menus:

- File
- Select
- Display
- Map
- Info
- Window
- Help
3.1. File

The File menu offers the following options:

- **Close** – closes the currently active window.

- **Save As** – saves the currently active window as a bitmap file.

- **Export Data** – allows the user to export **Gridded Data** or **Vector Data** from the GDA. Please see the **Export Data Dialog Box** section for further information.
  - **Vector Data** – allows the user to export data from the GDA in ASCII, DXF or Shapefile formats. Please see the **Export Formats** section for further details. This export option is only active if vector data sets have been selected.
  - **Gridded Data** – allows the user to export data from the GEBCO one minute gridded data set in NetCDF or ASCII formats. Please see the **Export Formats** section for further details. This option is only active if the GEBCO one minute gridded data set has been selected.

- **Copy to Clipboard** – copies the currently active window to the clipboard.

- **Page Setup** – opens the standard Windows page setup dialog box.

- **Printer Setup** – opens the standard Windows printer setup dialog box.

- **Print** – opens a standard Windows print dialog box allowing data from the currently active window to be printed.

- **Exit** – closes the GEBCO Digital Atlas Software Interface.
3.2. Select

The Select menu allows the user to specify the data sets and area required for display and export and the colours and styles to be used to display the data. A number of the options available from the Select and Display menus can be setup from the Chart Definition Dialog Box.

The Select menu offers the following options:

- **Chart Definition** – opens the Chart Definition Dialog Box
- **Area** – allows the user to select the chart series for the source of the bathymetric contour data (use the check boxes GEBCO and IBCM) and the area for which data are to be displayed and exported. Refer to the documentation available through the Info menu for further details on the available data sets.

The area selection is made using one of the following options:

  - **From the Map** – two further options are available:
    - **By Chart Area** – a world (for GEBCO) or Mediterranean (for IBCM) map is shown overlain by chart boundaries and reference numbers in red. The required chart is selected by double-clicking on it.
    - **By Zoom** – a world (for GEBCO) or Mediterranean (for IBCM) map is shown and the area is selected by clicking on diagonally opposite corners of a zoom box enclosing the required area.
  - **Exact** – precise geographic limits of the required area entered into dialog box fields. Co-ordinates may be entered in degrees, minutes and seconds, decimal degrees or degrees and decimal minutes. These options are changed by clicking the header bar of the dialog box.
  - **Chart Number** – permits selection of the desired chart from a drop-down list. Please note that the area selected will contain all data originating from the designated data set, but may also include data from adjacent data sets where the area is irregular in outline.

- **Bathymetric Contours** – allows selection of the contours to be displayed. Individual contours or groups may be selected using the left mouse button either alone or together with the Control and Shift keys in the usual Windows manner. Note that contour selection is provided through the Chart Definition Dialog Box. Three additional contour-selection buttons are provided:
o **Select All** – selects all the available contours from the GEBCO and IBCM chart series.

o **Invert** – inverts the previous selection of bathymetric contour depths. For example, if **Select All** has previously been used then **Invert** will deselect all bathymetric contours.

o **500s** – selects only the contours at 500 metre intervals.

- **Coastline** – allows selection of the coastline data set to be used for display and/or export from:

  o **GEBCO Coastline** – causes subsequent contour plots or data exports to include the coastline included in the GEBCO digital bathymetric contour data sets. Refer to the documentation (Info menu) which accompanies the digital bathymetric contour data sets for further information. If the user has selected to display data from the IBCM chart series then the coastline included in this data set will be used, please see the Info menu for further information.

  o **WVS Auto Resolution & SCAR Auto Resolution** – selects an appropriate scale of coastline from the World Vector Shoreline (WVS) data set. South of 60°S the Scientific Committee on Antarctic Research (SCAR) coastline is used rather than WVS. Refer to the documentation (Info menu) for further details on these coastline data sets. The display system automatically selects the source scale most appropriate to the current screen display scale or the source may be specified manually using the options that follow.

  o **WVS Full Resolution & SCAR Full Resolution**

    o **WVS 1:250000 & SCAR Full Resolution**

    o **WVS 1:1000000 & SCAR 1:1000000**

    o **WVS 1:3000000 & SCAR 1:5000000**

    o **WVS 1:12000000 & SCAR 1:10000000**

    o **WVS 1:43000000 & SCAR 1:10000000**

When **Auto Resolution** has been selected the following data sets are used for display and export:

- **Latitude and longitude range of less than 5 degrees – Full Resolution WVS and SCAR**

- **Latitude and longitude range greater than 5 degrees but less than 15 degrees – WVS 1:250000 & SCAR Full Resolution**

- **Latitude and longitude range greater than 15 degrees but less than 60 degrees – WVS 1:1000000 & SCAR 1:1000000**
- Latitude and longitude range greater than 60 degrees but less than 150 degrees – **WVS 1:12000000 & SCAR 1:10000000**

- **Supplementary Data** – allows the user to select the source of trackline control data to be displayed or included in any export of the data sets. There are two options available:
  - **GEBCO** – GEBCO trackline control information is used for any subsequent trackline control displays or data exports. The GEBCO tracklines represent the data coverage available for the compilation of the bathymetric contours for the GEBCO chart series. No digital trackline control is available for the IBCM data set.
  - **IHO DCDB** – trackline information from the International Hydrographic Organization Data Centre for Digital Bathymetry (IHO DCDB) to be used for any subsequent trackline displays or data exports. The IHO DCDB trackline information is supplied solely for the purpose of indicating the coverage of digital bathymetric data available from that source. The IHO DCDB data were not used in the compilation of either of the bathymetric contour data sets supplied (GEBCO or IBCM), and should not, therefore, be used as any indication of the confidence that may be placed in contours for a given area.

- **Graticule** – select the degree format and spacing of the chart graticule.
  - **Format** – set the format of the graticule label. The options are:
    - Degrees Minutes Seconds
    - Decimal Degrees.
  - **Display** – sets the format of the longitude values displayed on the graticule and also used for any export of the vector data sets. The options available are:
    - **0…360** – the longitude convention is 0° - 360°
    - **180..0..180** – the longitude convention is 180°W to 180°E with east positive and west negative
  - **Spacing** – sets the graticule spacing according to the options:
    - **Auto Spacing** – the software decides the appropriate graticule and changes it when zoom operations take place.
    - **Fractional** – a graticule is drawn with fractional grid spacing
    - **1 deg, 2 deg, 5 deg, 10 deg and 20 deg** – sets the graticule spacing to the value selected.
• **Projection** – specifies which of five available map projections is used when the selected data are plotted. Data exported from the system are independent of any cartographic projection. The projections available are:
  
  o Equidistant Cylindrical
  
  o Mercator
  
  o Lambert Cylindrical Equal-Area
  
  o Miller Cylindrical
  
  o Polar Stereographic – Please note that this option is only available for polar region data sets. From the initial area selection the region includes either 90°N or 90°S and the longitude range is 0°-360°E. If this option is selected the **Central Meridian** value to be used for producing the plot may be chosen.

• **Colour** – changes the colour used to display the data sets available in the GDA through a standard Windows dialog box with options:

  o **Coastline** – changes the colour used to plot the selected coastline data set – excluding the SCAR coastline, which is set from the menu item below

  o **Antarctic Coastline** – changes the colour used to plot the SCAR coastline.

  o **Contour Overlay** – changes the colour used to plot contours in ‘Overlay’ mode. Please see the **Display** menu for further information.

  o **Unselected Contours** – changes the colour used to plot unselected contours. Please see the **Display** menu for further information.

  o **Background** – changes the display window background colour. Please note that this is only seen for vector data sets but is used in the key and profile windows.

  o **Land** – changes the colour used to plot the land data as a single colour. Please see the **Display** menu for further information.

  o **Supplementary Data** – selects the colours to be used to display the following data sets:

    ▪ **Trackline Control** – the colours used for tracklines, survey boxes and isolated sounding points.

    ▪ **Undersea Features** – the symbol colour used to show the location of the feature.
- **Islands** – the symbol colour used to show the location of the feature.

- **Place Names** – the symbol colour used to show the location of the feature.

  - **Graticule** – changes the colour used to display the graticule.

  - **Query** – changes the colours used when the user ‘queries’ the value of a contour segment. Please see the Map menu for further details. The following may be set:
    - **Contour line** – changes the colour used to highlight the queried contour line.
    - **Contour text** – changes the colour used to display the queried contour’s depth value.

  - **Scheme** – selects a colour scheme from Red, Green, Blue, Rainbow, Light Rainbow and Black & White.

  - **Basemap Colour Range** – causes the colour palette to be set using the range of depths in the currently selected basemap area.

  - **Global Colour Range** – causes the colour palette to be set using the full range of depths from the GEBCO one minute grid.

  - **Reverse** – reverses the sense of the currently selected colour palette.

  - **Continuous** – causes the colour palette to have continuous colour levels.

  - **Discrete Gradation** – causes the colour palette to have discrete intervals, set from the dialog box, with the step size in metres.

- **Style** – sets the line style of the vector data sets (with the exception of the WVS and GEBCO coastline data sets) and the symbols used to display point data. The options available are:

  - **Bathymetric Contours** – sets the style used to display bathymetric contours

  - **Supplementary Data** – sets the display style for:
    - **Trackline Control**
    - **Undersea Features**
    - **Islands**
    - **Place Names**

  - **Graticule** – sets the display style for the graticule.

  - **Overlay** – changes the style of contours displayed as an overlay. Please see the Display menu for further information.
3.3. Display

The Display menu has five main functions that provide:

- Control over which data sets from the current selection are to be displayed or made available for export
- Control over the automatic redraw facility
- Control over the contents of the profile plot window
- Control over the visibility of supplementary data sets
- Control over the visibility of the map key

The Display menu offers the following options:

- **Auto Redraw** – toggles the facility which automatically redraws the current display windows each time the list of data items selected for display has been changed. If the option is turned off, the screen is redrawn manually when required using the Redraw button.

- **Bathymetric Contours** – controls the bathymetric contour data included in display and/or export. There is a submenu:
  
  - **Display** – toggles the plotting of the currently selected range of bathymetric contours (chosen using the Select menu) and using the current selection of line styles and colours.
  
  - **Unselected** – toggles the plotting of any bathymetric contours that fall within the currently selected geographic area but have not been selected for display. These contours are drawn in one colour, specified through the Select – Colour menu. They are not included in any export of the data from the currently selected area. They will only be displayed if the Display option (described above) has been toggled on.
  
  - **Overlay** – toggles the plotting of bathymetric contours as an ‘overlay data set’. The contours are all plotted in one colour which can be defined through the Select – Colour menu. This option could be useful when plotting bathymetric contour with the gridded data set. Contours displayed will be included in any export of the data. They will only be displayed if the Display option (described above) has been toggled on.

- **Coastline** – toggles the plotting of the currently selected coastline data set. The coastline is plotted using the current colour which can be selected from the Select – Colour – Coastline menu. The coastline data set to be displayed can be selected from the Select – Coastline menu or through the Chart Definition Dialog Box from the Select menu.
• **Gridded Data** – activation of this menu option (which acts as an on/off toggle) will cause the GEBCO gridded data set to be displayed on screen and to be available for any export of the data for this area.

• **Single Land Colour** – this menu option is only active if the GEBCO one minute grid has been selected for display. It acts as an on/off toggle that causes the land to be displayed in a single colour, which can be set from the Select – Colour – Land menu.

• **Supplementary Data** – this option provides a list of supplementary data sets that are available for display on screen and in the case of trackline control data for export. The following are available:
  
  o **Trackline Control** – this option allows the user to toggle the display of trackline control data. The source of the trackline data set (either GEBCO or IHO DCDB) can be selected from the Select – Supplementary Data – Trackline Source menu. The trackline control for the IHO DCDB data set consists of tracklines only. The GEBCO data set contains trackline control in the form of tracklines, isolated sounding points and survey boxes or a combination of these data types. The user may select these trackline control data types separately, but should be aware that they may all be valid in a particular area.

  o **Undersea Features** – this option allows the user to toggle the display of the locations of undersea features (as referenced in the IHO/IOC Gazetteer of Geographical Names of Undersea Features). The style and colour of the symbol used to show the location the undersea features can be set through the Select menu. Information relating to the undersea feature can be found by using the Query option from the Map menu.

  o **Islands** – this option allows the user to toggle the display of the locations of oceanic and Antarctic islands. The style and colour of the symbol used to show the location of the islands can be set through the Select menu. The name of the island can be found by using the Query option from the Map menu.

  o **Place Names** – this option allows the user to toggle the display of the locations of ports/cities and Antarctic stations. The style and colour of the symbol used can be set through the Select menu. The place name can be found by using the Query option from the Map menu.

• **Graticule** – activation of this menu option (which acts as an on/off toggle) will cause a geographic latitude and longitude graticule to be displayed on the screen. The format of the graticule may be defined through the Select – Graticule menu. Buttons on the toolbar can also be used to change the format of the graticule.
• **Key** – activation of this menu option toggles the map key on the screen.

• **Profile** – this option allows the user to control information displayed on the profile plot that is setup from the **Map** menu. There are three options that may be toggled on and off:
  
  o **Sea Level** – shows the position of 0m depth on the profile plot.
  o **Way Points** – shows the position of any turning points as a vertical line on the profile plot.
  o **Distance** – displays the distance travelled from the start of the profile plot in nautical miles.
3.4. Map

This menu is only available when a data set has been selected and displayed on screen. It provides options for the user to:

- Zoom in to an area of the display screen
- Draw profile plots across the data set
- Query information about some of the data sets displayed
- Carry out distance measurements
- Carry out calculations using Carter’s Tables

The Map Menu has the following options:

- **Zoom In** – zooms into a selected area of the current display (base map) screen by either defining a zoom box using the cursor interactively on screen or by entering the latitude and longitude co-ordinates of the required area. The shape of the zoom box is controlled using the **Box Shape** options.
  
  - **From The Map** – defines a zoom box using the cursor as specified by the current box shape option.
  
  - **Exactly** – defines a zoom box by entering the exact longitude and latitude co-ordinates through a dialog box. The chosen area must be within the area of the original base map. Values may be entered in degrees, minutes and seconds, degrees and decimal minutes or decimal degrees. The desired format is selected using the **degrees**, **minutes** and **seconds** buttons.
  
  - **Box Shape** – dictates the degree of user control over the shape of the zoom box, which may be:
    
    - **Defined During Zoom** – causes the shape of the zoom area selected during subsequent **Zoom In** commands to be fully under user control (i.e. the zoom area may be ‘tall thin’ or ‘short fat’, which will only partially fill the display area when plotted).
    
    - **Use Window Proportions** – causes the shape of zoom area selected during subsequent **Zoom In** commands to be constrained to the same height to width ratio as the display area, so that the resulting plot will completely fill the display area.

- **Zoom Out** – causes the display to zoom out to the previous zoom level. It is only available when an initial zoom region has been selected and displayed.
- **Adjacent** – repositions the current display. The user may specify the required percentage overlap of the current display window and also the direction of the overlap (**North**, **South**, **East** or **West**). The percentage overlap is specified in the **Map – Adjacent – Overlap** option.

- **Query** – permits the user to query individual items within the current dataset to obtain additional information. Only those items currently selected can be queried. When an option under this menu heading is activated, the cursor changes to a cross within a circle with the subscript ‘Q’. The query mode is terminated by returning to the **Map – Query** menu and toggling the item off or by selecting another menu option in some cases. The following may be queried:
  
  - **Contours** – returns the precise depth of individual contour lines within the current dataset.
  
  - **Features** – displays information on screen from the IHO/IOC Gazetteer of Geographic Names of Undersea Features. This option is only active if the **Undersea Features** have been selected for display.
  
  - **Islands** – displays the names of queried islands on screen. This option is only active if **Islands** have been selected for display.
  
  - **Place Names** – displays the names of queried place names on screen. This option is only active if **Place Names** have been selected for display.
  
  - **Survey Boxes** – queries survey boxes within the current dataset in order to determine their source reference.
  
  - **Distance** – allows measurement of the cumulative distance along a multi-segment line on the displayed chart in nautical miles, statute miles or kilometres. All distances are computed as the 'great circle' distance between turning points in the line (i.e. the shortest distance between those points on the surface of a sphere).

  When the option is activated the cursor appears as a cross within a circle with the subscript 'D'. The starting point for distance measurement is set by positioning the cursor at the required location and left-clicking. This position is now the anchor at one end of a 'rubber band' line, with the cursor bound to the other. Moving the mouse repositions the cursor (and line). The current 'on the ground' distance between the present cursor position and the anchor point is continually output at the top of the display. Turning points are created by left-clicking when the cursor is at the desired location. The line is terminated by double-clicking.

  - **Carter’s Tables** – allows determination of the echo-sounding depth correction for a specified location using the Third Edition of the Echo-
Sounding Correction Tables ("Carter's Tables"). The conversion may be either to or from corrected metres.

When the option is activated the cursor appears as a cross within a circle with the subscript 'C'. The location for echo-sounding depth correction is specified by positioning the cursor and left-clicking, causing the **Carter's Tables Dialog Box** to be opened. The direction of the depth conversion is controlled by radio buttons. Selecting another item from the menu bar toggles the Carter's Tables option off.

- **Cursor Position** – offers control over the status (visible or hidden) and numerical format (degrees, minutes and seconds or decimal degrees) of the cursor information (current position and location elevation).
  - **On The Map** – displays the cursor position information on screen in a box. The colour of this box and the colour of the display text are set through a series of menu options (**Background** and **Colour**). **Overlay** - makes the background colour of the on-map box transparent.
  - **In the Caption** – displays the cursor position information in the caption bar of the display window.
  - **Format** – controls the way in which the current cursor location is displayed.

- **Profile** – generates a profile plot (vertical section) from the data set. The elevation information is taken from the GEBCO one minute grid.

Once this option has been activated, the **Bathymetry Profile** window opens and the cursor changes to a cross within a circle with subscript ‘P’. Left-clicking anywhere on the map display drops an anchor and any subsequent cursor movement cause the cross-section along the line between the cursor and the anchor to be plotted in the **Bathymetry Profile** window. Turning points in the profile line may be set by left-clicking. The profile is completed, freezing the profile displayed, by double-clicking.

The elevation information is shown in metres on the vertical axis of the plot in the profile plot window. The format of the x axis may be controlled by options in the **Display – Profile** menu.
3.5. Info

This menu provides access to the descriptive texts covering the datasets included in the GDA and the export formats used by the GDA software. The information may be viewed on the screen or printed.
3.6. Window

The Window Menu offers the following display control options:

- **Toolbar** – toggles the display of the Toolbar.
- **Fit to Screen** – controls the size of the image file drawn on the screen.
- **Bold Text** – determines whether the text in dialog boxes is displayed in bold text.
3.7. Help

The Help menu has the following options:

- **About** – displays a window giving information on copyright and the version number of the GDA Software Interface.


- **Software User Guide (pdf)** – launches Acrobat Reader with this file loaded.

- **WWW Homepages** – provides a list of useful web pages.
4. GDA Software Interface Toolbar

The Toolbar contains a selection of icons which affect the screen display.

The functions of the buttons are listed below. Their names are displayed in hints when the cursor is over the button. A number of the functions of the Toolbar buttons can also be carried out through Main menu options.

- **Page Setup** – opens the standard Windows page setup dialog box. This option is also available from the File menu.
- **Print** – opens the standard Windows print dialog box. This option is also available from the File menu.
- **Print Setup** – opens the standard Windows print setup dialog box. This option is also available from the File menu.
- **Save File** – saves the image in the currently active window as a bitmap (bmp) file or displayed text information as a text file. This option is also available from the File menu.
- **Copy to Clipboard** – copies the image or text in the currently active window to the clipboard.
- **Coastline Colour** – opens a dialog box that allows the user to alter the coastline colour in the current display. This can also be done from the Select – Colour menu.
- **Background Colour** – opens a dialog box that allows the user to specify the background colour of any of the display windows. This can also be set through the Select – Colour menu.
- **Graticule : Toggle the display** – toggles the display of graticule. This can also be done from the Select - Colour menu.
- **Graticule : Colour** – allows the user to specify the colour of the graticule through a dialog box. This can also be done from the Display menu.
- **Graticule: Auto** – a graticule is drawn with the optimal grid spacing for the displayed area.
- **Graticule: Fractional** – a graticule is drawn with fractional grid spacing.
- **Graticule Spacing 1 deg 2 deg 5 deg 10 deg 20 deg** – a graticule is drawn with the specified grid spacing.
- **Graticule Font Size increment buttons** – allow the user to increase or decrease the font size of the graticule labels.

- **Graticule Display: Degrees Minutes Seconds** – allows the user to display the graticule labels in the format Degrees, Minutes and Seconds.

- **Graticule Display: Decimal Degrees** – allows the user to display the graticule labels in decimal degrees.

- **Show the position of the cursor** – toggles the display of the cursor position on the map.

- **Cursor Position: Degrees Minutes Seconds** – allows the user to display the cursor position in degrees minutes and seconds.

- **Cursor Position: Decimal Degrees** – allows the user to display the cursor position in decimal degrees.